Fallout4 Mod データベース

 Fallout 4 Version Check Patcher [その他] ID:42497 Author:dm 2019-12-10 15:04 Version:1.00

RATE: =151 G=6 [DOWNLOAD SITE]
TAG: [ユーティリティ] [F4SE]
Fallout 4 Version Check Patcher Title画像

Fallout 4 Version Check Patcher

このF4SEプラグインは、古いバージョンの本体EXEが新しいプラグイン(要はespとかesmとかesl)を読み込む際に、バージョンチェックを回避させて動作できるようにさせます。

Bethesdaは2019年11月のアップデートでFallout4のheaderのバージョン値を1.0に変更しました。また、同時期にリリースされた新しいCKで作られたMODのプラグインのheaderバージョン値も1.0になるようになりました。
Fallut4のheaderバージョン値はこれまで0.95だったため、なんらかの理由でFallout4本体のアップデートを保留にしている場合には、新しいCKで作られたMODのプラグインを読み込むことができません。

このF4SEプラグインを使うことで、古い本体EXEでもHeader値が1.0のMODのプラグインを読み込むことができます。結果としては、EditerでプラグインのHeader値を手動で1.0から0.95に変更することと同じ効果が得られます。
  • Fallout 4 Version Check Patcher画像1
Fallout4 Nexus, dm. 10 Dec 2019. Fallout 4 Version Check Patcher. 10 Dec 2019 <https://www.nexusmods.com/fallout4/mods/42497>.
2019-12-29 00:09:38 [編集する] [差分] [日本語化UP]


上記説明は古い又は異なる場合があります。導入の際はDescriptionを確認の上、自己責任でお願いします。
説明はどなたでも編集する事が可能です、古い又は異なる場合は編集にご協力をお願いします。

To users except in Japan
コメントコメントだけでも投稿できます。気に入ったMODはNEXUSでもENDORSEしましょう。
[Spoiler]テキスト[/Spoiler]とする事で隠しテキスト、#や>>後、半角数字でアンカーを使用可。
-
  • File (3MB以下) ZIP,RAR,7z,LZH
  • Version
  • Del Key (削除用)
  • Support Tool

▼ コメントは任意で入力して下さい(入力するとアンカーが付きます)

  • Name0/8
  • Comment0/1000
  • MOD評価
  • 書込
 
▼ Version : 1.00
#18
名無し
一応追加報告
xxx0000A ~ xxx0000F もダメでした、振り直しが必要です(16進数なのをど忘れしていた上に、この6個はスクリプトのプロパティになっていなかったので気づくのが遅れました)
xxx00010 以降は読み込んでいるようです、がおま環かもなので参考までに

#17
自分はPS4北米版からPCへMODのためにWindows OSを購入してまで移行した口なので、MODを自由に選択したり改造したりしたかったらPC版がええよ、という感じです   ID:k4OGEyY2 Day:482 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#17
名無しGood!
#15
いやいや、勉強になりました

このMODやヘッダーを書き換えるのは恒常的な対策ではなく
F4SEのバージョンが追いつくまでの一時的な対策とか、そういう用途と見たほうが良さそうです
無意味にバージョンチェックしているわけではないですから、やはりゲームのバージョンを最新にしておかないと何らかの不具合は出ると思います
日本語版でプレイしている人は英語版日本語化のいい機会かもしれませんね
PCはそれで良いけど、問題はXBONEやPS4の人達
どうしたらいいんでしょうね、今後は北米版で遊ぶしか無いのか   ID:I1Y2UyYj Day:305 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#16
3/2
>> 新規の FormID は大抵 xxx00801 から割り振られるもので
すみません、xxx00800 から、の間違いです...   ID:k4OGEyY2 Day:480 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#15
2/2
-----
Null のままですとゲームがそのデータを扱えませんので、その MOD は大抵正常に働きません
また、今回の私の場合はその MOD が使っているスクリプトに GetFormFromFile() などを使い FormID から直接プロパティを取っている部分がありませんでしたので、FormID を振り直すだけで大丈夫でしたが、そういう仕組みを使っているスクリプトがある MOD ですと、FormID を振り直すだけでは直りません、スクリプトの修正も必要です
その MOD が何か別の MOD のマスターになっているのならなおさら、FormID を振り直すと不具合が出ます
-----
こちらの MOD はヘッダー値のチェックをスキップする、とのことですので、恐らく旧版 exe で読み込めない FormID は読み込めないままだと思います
Desc にもそういった注意書きがあります
ヘッダー値を変更して MOD を使用される場合は、エラーログを取って確認されることをお勧めします
長い上に読みづらい内容で申し訳ありません   ID:k4OGEyY2 Day:480 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#14
1/2
JUMP PADS の方に(ヘッダー云々が今がこうなってるよ、という)元のコメントを書いた者ですが、ヘッダー値を0.95に変更して使用することについての不具合を見つけたので一応こっちへ報告しておきます
この MOD さんには関係あるような、ないような
-----
まず新しいバージョンでの変更点のひとつに、各 esp やらが扱える FormID の数が増えた、という変更があります

それでですね、自環境でヘッダー値を 1.0 から 0.95 に書き換えた esp を、FO4 をスタートして読み込んだ時に、"このスクリプトのいくつかのプロパティが <nullptr form> だからアカンですよ"、というエラーログが 9 行出ていたんです
ReSaver でセーブデータも確認したところ、その 9 個は確かに Null になっていました

で、調べたところ、スクリプト自体や esp 側の不備はありませんでした

これは当てずっぽうなんですが、それらエラーログに表示されているプロパティの FormID が xxx00001 ~ xxx00009 だったんです
これまでは、新規の FormID は大抵 xxx00801 から割り振られるもので、それ以下のものを見かけた覚えがありませでした
ですのでその記憶を頼りに、試しにそれら 9 個の FormID を FO4Editで 新規に振り直してやったところ、無事読み込まれるようになり、エラーログも出なくなりました
セーブデータのスクリプトインスタンスも正常に表示されていました   ID:k4OGEyY2 Day:480 Good:4 Bad:0
  • Good
  • Bad
  • 42497
#13
名無しGood!
#12
VRもバージョン追いついてないの?
それにしても家庭用のユーザー大変だなこれは   ID:M3MmRjNW Day:10 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#12
名無しGood!
これFallout4 VRでも動いた。
VRでは必須になると思う。
ちょうどWryeBashが警告を出してたespが読めてなかったので、ようやく合点がいった、、   ID:Q4N2Q5Zj Day:469 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#11
名無し
>Bethesdaは2019年11月のアップデートでFallout4のheaderのバージョン値を1.0に変更しました。
今こんなことになってたのね… このMod入れれば解決とはいえ、初心者が情報にたどり着けるか疑問だし、ずいぶん敷居が高くなっちゃったな
F4SEプラグインの関係で昔のバージョン使ってるから、これからお世話になりそう。

#9 コンシューマーは持ってないんで完全に推測で答えるけど、おっしゃる通りだと思う。   ID:VlMGM0Nj Day:0 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#10
名無し
もしそうならコンシュマー版はFallout4終了のお知らせだな…   ID:g2NDUwNG Day:8 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#9
名無しGood!
若干スレ違だけど、今回のアップデート問題ってXBONEやPS4の場合どうなんでしょう
日本語版で遊んでる人はゲーム本体がこのアップデートについていってないので最新MOD遊べない訳ですが、日本語版更新されてないのってコンシュマーも同じだと思うんですけど同じ症状出るんでしょうかね
コンシュマーはPCみたいにFO4S使ったり自分でヘッダー直したりできないので、日本語版遊んでる人は今後新しいMOD対応や既に入れてるMODのアップデートは絶望的になるの?
教えてエロい人   ID:g2NDUwNG Day:8 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#8
名無し
#7
そのとおり。現時点での最新Ver以降にアップデートしてれば不要です。   ID:JkZDNhND Day:393 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#7
名無し
英語版で最新にしてる人には関係ないmodなのかな   ID:BhZTMyYm Day:0 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#6
名無しGood!
最近あちこちで聞くmodが使えないって話はこれ(がFIXしてくれるバージョンアップ)が原因だったか   ID:hlZGRiYz Day:382 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#5
名無しGood!
ようやくこのMODの本当の意図がわかったので説明文書きました。しばらくの間、Fallout4のアップデートを保留にしている人はとりあえず突っ込んどけ的なMODかもしれません。

酒飲みながら説明文書いたので説明文が辺なところや分かりにくいところがあれば修正よろしくおねがいします。   ID:JkZDNhND Day:387 Good:6 Bad:0
  • Good
  • Bad
  • 42497
#4
名無し
これでmodderの過労死を防げるようになればいいね。   ID:FiYjIwNG Day:5 Good:1 Bad:0
  • Good
  • Bad
  • 42497
#3
名無し
#2
んー。逆じゃないかな。バージョンチェックをバイパスすることで、古いバージョンの本体EXEでもより新しいF4SEプラグインを動かせる、とDescに書いてあるように読める。
本体のバージョンアップをしないでも、新しく出てきたF4SEプラグインを動かせるようにするってのが趣旨なんじゃまいか?
違ってたらスマヌ・・・   ID:lmNzA2ZW Day:368 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#2
名無しGood!
つまり…本体が最新のバージョンでも更新がされてなくて動かせないスクリプトMODを動かせるってこと?   ID:c0ODQ3NT Day:168 Good:0 Bad:0
  • Good
  • Bad
  • 42497
#1
名無し
古いEXEを新しいプラグインで動かす?! すごすぎじゃないでしょうか
夢のようなプラグイーン   ID:JmMDc5ZG Day:807 Good:1 Bad:0
  • Good
  • Bad
  • 42497
作者(dm)さんのMOD※Authorの検索結果のため別作者さんのMODが表示される場合があります。
  • Fallout 4 Version Check Patcher画像
    =162 G=6
  • Advanced Workshop Food Harvesting画像
    =18 G=4
  • BoS Vertibird DLC Locations画像
    =3


Real Time Information!CLOSE
1593694147 1593528895 1593802824 none none
42497
▲ OPEN COMMENT